Blackboard Knowledge Wiki

Knowledge Wiki logo

Supported Browsers, Plugins & Operating Systems for Blackboard Learn Release 9

Skip to end of metadata
Go to start of metadata

Supported Web Browsers

Blackboard is committed to supporting the two most recent versions of client software for each major release of Blackboard Learn™ when possible. These levels of support may change depending on contractual obligations or lack of support from vendors. The following tables list the supported operating systems and browsers for use with Blackboard Learn Release 9.

9.0 Service Pack 7 is the latest release on 9.0. The Supported Browsers can be found here: Release 9.0 SP7 Supported Browsers & Operating Systems

For earlier releases of 9.0, identify the version of Blackboard you are using and check the links at the bottom of this page.

Key to Support Status

Term Definition
Certified fully tested and supported.
Compatible key application areas tested.
Provisional
future technologies considered supported by Blackboard Support.
Not Supported specified Browser is not supported for the Operating System.

Microsoft® Internet Explorer® Web Browsers

Browser Windows XP Windows Vista 32-bit Windows Vista 64-bit Windows 7 (32/64-bit)
Mac OS 10.3 Mac OS 10.4 Mac OS 10.5
Internet Explorer 8 (Standards Mode Only) Compatible Certified Compatible Certified Not Supported Not Supported Not Supported
Internet Explorer 7 Compatible Compatible Compatible Not supported
Not Supported Not Supported Not Supported

Mozilla® Firefox® Web Browsers

Browser Windows XP Windows Vista 32-bit Windows Vista 64-bit Windows 7 (32/64-bit)
Mac OS 10.3 Mac OS 10.4 Mac OS 10.5 Mac OS 10.6
Firefox 3.6.x
Compatible
Certified (in 9.0 SP5) Compatible Certified (in 9.0 SP5) Not supported Not Supported
Compatible Certified (in 9.0 SP5)
Firefox 3.5.x (1)
Certified (in 9.0 SP2)
Certified (in 9.0 SP2)
Compatible (in 9.0 SP2)
Provisional
Not Supported
Certified (in 9.0 SP2) Certified (in 9.0 SP2) Provisional
Firefox 3.0.x (2) Certified Certified Compatible Not Supported Not Supported Compatible Certified Not Supported
Firefox 2.0.x (3) Not Supported Not Supported Not Supported Not Supported Not Supported Not Supported Not Supported Not Supported
Firefox 1.5.x (3) Not Supported Not Supported Not Supported Not Supported Not Supported Not Supported Not Supported Not Supported
  1. Firefox 1.5 and 2.0 are not supported for Blackboard Learn. It is recommended that Firefox 1.5 and 2.0 users upgrade to Firefox 3.0 or above to access the latest security patches and Mozilla support.

Apple® Safari® Web Browsers

Browser Windows XP Windows Vista Windows 7
Mac OS 10.3 Mac OS 10.4 Mac OS 10.5 Mac OS 10.6
Safari 5
Not Supported Not Supported Not Supported Not Supported Not Supported Compatible
Certified (in 9.0 SP5)
Safari 4 Not Supported Not Supported Not Supported Not Supported Certified (in 9.0 SP2)
Certified (in 9.0 SP2)
Provisional
Safari 3 Not Supported Not Supported Not Supported Not Supported Certified Certfied Not Supported
Safari 2 Not Supported Not Supported Not Supported Not Supported Compatible Compatible Not Supported

Sun™ Java™ Virtual Machine

For all operating systems, the supported version is Java Standard Edition 5 (1.5.0_12) and later. As of the release of Service Pack 1 the Java SE 6 runtime environment is also supported.

Labels

supportedbrowsers supportedbrowsers Delete
Enter labels to add to this page:
Please wait 
Looking for a label? Just start typing.