Blackboard Knowledge Wiki

Knowledge Wiki logo

Supported Browsers, Plugins & Operating Systems for Vista and CE Release 8

Skip to end of metadata
Go to start of metadata
To Determine your version of Vista/CE: Go to the Entry Page of your Blackboard server and click Check Browser. Your version of Blackboard displays at the top of the Browser Check screen.

If you are using Vista/CE 8.0.3, 8.0.4, 8.0.5, or 8.0.6 please see the release-specific pages below:

Vista 8.0 SP3 Supported Browsers & Operating Systems
Vista 8.0 SP4 Supported Browsers & Operating Systems
Vista 8.0 SP5 Supported Browsers & Operating Systems
Vista 8.0 SP6 Supported Browsers & Operating Systems

Supported Web Browsers - Only for Vista/CE Release 8.0 GA through SP2 (8.0.2)

Listed below are the supported operating systems and browsers for use with the Blackboard Academic Suite. The Academic Suite is a Web-based application and other browsers and operating system may work well, however, the listed configurations are the only configurations that are tested and supported by Blackboard.

Term Definition
Certified fully tested and supported
Compatible key application areas tested
Provisional
future technologies considered supported by Blackboard Support
Not tested specified Browser is not supported for the Operating System

Microsoft® Internet Explorer® Web Browsers

  Windows 2000 Windows XP Windows Vista Desktop Windows 7 (32/64-bit)
Internet Explorer 6 Not Tested Compatible Not Tested Not Tested
Internet Explorer 7 Not Tested Compatible Certified Not Tested
Internet Explorer 8
Not Tested
Certified (8.0.3 and up)
Certified (8.0.3 and up)
Certified (8.0.4 and up)

Deprecated:

  • Internet Explorer 5.2
  • Internet Explorer 5.5
  • Not Tested on Mac OS (all versions)

Netscape® and Mozilla® Firefox Web Browsers

  Windows 2000 Windows XP Windows Vista Desktop Windows 7 (32/64-bit)
Mac OS 10.2 Mac OS 10.3 Mac OS 10.4 Mac OS 10.5 Mac OS 10.6
Firefox 2.0 Not Tested Compatible Certified Not Tested Not Tested Compatible Compatible Certified Not Tested
Firefox 3.0 Not Tested Certified Certified (with 8.0 SP2) Not Tested Not Tested Not Tested Not Tested Not Tested Not Tested
Firefox 3.5
Not Tested
Compatible with 8.0 SP3 HF1 Compatible with 8.0 SP3 HF1 Compatible with 8.0 SP3 HF1 Not Tested
Not Tested
Compatible with 8.0 SP3 HF1 Compatible with 8.0 SP3 HF1 Compatible with 8.0 SP3 HF1
Firefox 3.6
Not Tested Compatible
Certified
Certified
Not Tested Not Tested Not Tested Cerified
Certified

Deprecated:

  • Netscape 7.1
  • Netscape 8.0
  • Firefox 1.0
  • Firefox 1.5

Apple® Safari® Web Browsers

  Mac OS 10.3 Mac OS 10.4 Mac OS 10.5 Mac OS 10.6
Safari 2 Compatible Compatible Not Tested Not Tested
Safari 3 Not Tested Compatible Certified Not Tested
Safari 3.1 Not Tested Compatible Certified (with 8.0.2) Not Tested
Safari 3.2
Not Tested
Compatible
Certified
Not Tested
Safari 4
Not Tested
Certified with 8.0 SP4
Certified with 8.0 SP4 Certified with 8.0 SP4

Deprecated:

  • Safari 1
  • Safari 1.1
  • Safari 1.3
  • Mac OS 10.2
  • Not Tested on Windows (all versions)

Supported Java Run-Time Versions

The following information presented on Java Run-Time Environment compatibility reflects the results of latest testing information. Blackboard continually tests its products and is committed to notifying our clients as soon as possible regarding any changes.

Some clients have experienced difficulties with the latest version of the Java Run-Time Environment (1.6). It is recommended that an older iteration of 1.6 be used if problems occur. Contact Blackboard Support for further information regarding this issue.

Blackboard supports the following versions of the Java Run-Time Environment to run in concert with CE and Vista version 8.

Sun 1.4.2 (1.4.2_06 minimum)
Sun 1.4.3
Sun 1.5.x (excluding 1.5.0_02)
Sun 1.6.x
IBM 1.4.x
Apple 1.3.x
Apple 1.4.x

Enter labels to add to this page:
Please wait 
Looking for a label? Just start typing.